1. Welcome to For Trucks Only !

    We are a community of American Brand Pickup Truck and SUV owners. Join now! Its Free!

    Dismiss Notice

Need help

Discussion in 'Classic Dodge Trucks - Pre 1981' started by Jean-Guy, Sep 1, 2019.

Tags:
  1. Jean-Guy

    Jean-GuyMember

    Messages:
    8
    Likes Received:
    5
    Joined:
    Nov 27, 2015
    Location:
    New-Brunswick
    hi there everyone
    I got an 77 D100 adventurer with a rebuilt 360 pushing 400hp
    It’s been running fine until 3 weeks ago,started stalling,sputtering,accelerate great,but at steady speed it keeps jogging in and out,I work 2 weeks on and 2 weeks off,when I came back yesterday,i started it,idle perfect for 15 min,then when I shut it off,started back up,it started doing the same things,I change everything I could think off,I go to 2000 rpm and hold it there,then it will go down to 500 rpm by itself and go back up,but it starts perfect, any help would be appreciated,thanks in advance

    0F98F8B2-20C7-45EA-8B59-989952E2313F.jpeg
     
    • Like Like x 1
    • Cranky1

      Cranky1Old Stinky Fart

      Messages:
      198
      Likes Received:
      55
      Joined:
      Jun 4, 2011
      Location:
      Paserdener TX
      Have you done anything with the carb? Might have some trash in it.....
       
    • Jean-Guy

      Jean-GuyMember

      Messages:
      8
      Likes Received:
      5
      Joined:
      Nov 27, 2015
      Location:
      New-Brunswick
      I had a 2 brand new carb ,I use the second one,doing the same thing,what’s funny is I can start it after 2 or 3 days it won’t do it until I stop it and start it again
       
    • Cranky1

      Cranky1Old Stinky Fart

      Messages:
      198
      Likes Received:
      55
      Joined:
      Jun 4, 2011
      Location:
      Paserdener TX
      Stock electronic ignition? Have you swapped out that out yet. There's supposed to be ways to test all that but heck if I remember what you need. Pickup inside the distributor going out? Had a broken distributor pickup wire on an 88 Shadow that made it run bad at times and even die once it got hot. It was bad just outside of the distributor body....
       
    • Jean-Guy

      Jean-GuyMember

      Messages:
      8
      Likes Received:
      5
      Joined:
      Nov 27, 2015
      Location:
      New-Brunswick
      Will try that thanks will let you know
       
      • Like Like x 1
      • Basketcase

        BasketcaseWell-Known Member

        Messages:
        113
        Likes Received:
        102
        Joined:
        May 21, 2018
        Location:
        Ohio
        I'd do the remote gas tank bit (gallon or more jug) to rule out clogged fuel line, and or tank filter. And change the line filter while you're at it.
         
      • Jean-Guy

        Jean-GuyMember

        Messages:
        8
        Likes Received:
        5
        Joined:
        Nov 27, 2015
        Location:
        New-Brunswick
        Thanks I will give that a go
         
      • Basketcase

        BasketcaseWell-Known Member

        Messages:
        113
        Likes Received:
        102
        Joined:
        May 21, 2018
        Location:
        Ohio
        good looking truck!
         
      • Jean-Guy

        Jean-GuyMember

        Messages:
        8
        Likes Received:
        5
        Joined:
        Nov 27, 2015
        Location:
        New-Brunswick
        Thanks,Im restoring a 78 Midnite Express too,I got 85 percent done,I’ll put up pictures soon
         
        • Like Like x 1
        • Jean-Guy

          Jean-GuyMember

          Messages:
          8
          Likes Received:
          5
          Joined:
          Nov 27, 2015
          Location:
          New-Brunswick
          Yours is pretty good looking too
           
          • Like Like x 1
          1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
            By continuing to use this site, you are consenting to our use of cookies.
            Dismiss Notice