• Welcome to For Trucks Only !

    We are a community of American Brand Pickup Truck and SUV owners. Join now! Its Free!

07- Z71 Check engine light on

Alleycat

Member
Joined
Sep 7, 2013
Messages
11
Reaction score
1
Location
Florence, Ms
This truck doesn't get driven much anymore. Less than 1k last year. Got in it the other day and the check engine light came on. Took it to Auto Zone to have codes read. Came up with: P0442, Evaporative emission system- Small leak/ no flow condition. Probable cause:
Defective or loose fuel cap. took it off, checked it, looks good, put it back on tight, engine light still on.
Don't have a clue where to begin with the following:
Evap canister or hose cracked-not connected.
Purge or vent solenoid defective.
Vacuum leak at engine.
P3400, Cylinder deactivation system performance.
The control module detects that the actual measured values from the MAF sensor, MAP sensor, and TP sensor, is not within the range of the calculated values for V4 mode.
What??? The truck seems to be running fine, and goes in and out of V4 mode when cruising as it always has done.
Has anyone had experience with these codes? What did you do to fix it? I was a good mechanic back in the points, plugs and condensers days. Totally clueless now.
 

Paul

New Member
Joined
Jun 16, 2011
Messages
2
Reaction score
0
Location
San Carlos, Ca
Sometimes after so many starts it will reset, don't know how many. Most common way is with the tool used to read the code.
 

Alleycat

Member
Joined
Sep 7, 2013
Messages
11
Reaction score
1
Location
Florence, Ms
OK, thanks again. Looks like another trip to AutoZone to kill the light. I guess if it doesn't go off, it's not fixed, and I'm back to square one.
 
Top