1. Welcome to For Trucks Only !

    We are a community of American Brand Pickup Truck and SUV owners. Join now! Its Free!

    Dismiss Notice

No Spark

Discussion in 'General Dodge Truck Discussions' started by Power Wagon 440X4, Jul 19, 2019.

  1. Power Wagon 440X4

    Power Wagon 440X4Active Member

    Messages:
    76
    Likes Received:
    17
    Joined:
    Aug 8, 2015
    Location:
    Texas
    85 W150 318
    I installed a new ECM, Ballast, & Coil.
    All the fuseable links and places that should have power light up the test light except the Negative side of the coil.

    Is there anything in the interior wiring that would prevent exterior wiring from working?

    The only thing plugged in on the inside is the steering column to turn it over with the key.
     
  2. paul massaro

    paul massaropomonamissel

    Messages:
    471
    Likes Received:
    288
    Joined:
    Apr 18, 2017
    Location:
    san jose california
    does the key switch perviding 12v dc during cranking ?
     
  3. Power Wagon 440X4

    Power Wagon 440X4Active Member

    Messages:
    76
    Likes Received:
    17
    Joined:
    Aug 8, 2015
    Location:
    Texas
    I don't have a test meter.
    The light is bright on all hot circuts and is getting power all the way to the positive side of the coil.

    I have a new ignition switch that I can plug in and try.
     
    Last edited: Jul 20, 2019
  4. HALIFAXHOPS

    HALIFAXHOPSBeerening at its best!

    Messages:
    1,723
    Likes Received:
    1,032
    Joined:
    Aug 6, 2015
    Location:
    Halifax, Centrural PA
    Can also be the pickup in the distributor or the gap is off should be .008
     
  5. Power Wagon 440X4

    Power Wagon 440X4Active Member

    Messages:
    76
    Likes Received:
    17
    Joined:
    Aug 8, 2015
    Location:
    Texas
    The distributor is rebuilt but that doesn't mean anything these days. There is no power at all getting to the distributor. No power on the Neg side of the coil to power the distributor.
     
  6. 7mopar

    7moparWell-Known Member

    Messages:
    1,711
    Likes Received:
    791
    Joined:
    Dec 21, 2013
    Location:
    Kingsville, MO
    Make sure the ECM is grounded real good. That is a must for it the function correctly. Do you have the test procedures for the ignition system?
     
  7. Power Wagon 440X4

    Power Wagon 440X4Active Member

    Messages:
    76
    Likes Received:
    17
    Joined:
    Aug 8, 2015
    Location:
    Texas
    No Sir I do not have a procedure but willing to learn.
    I will check the ECM ground.
    Would the pos side of the coil get power if the ECM was not grounded?
     
  8. Power Wagon 440X4

    Power Wagon 440X4Active Member

    Messages:
    76
    Likes Received:
    17
    Joined:
    Aug 8, 2015
    Location:
    Texas
    I had to get into the column to replace a broken turn signal switch anyway so I went ahead and added a new ignition switch. Still no power to the neg side of the coil with the key on. I installed an older ecm and I get a green light from the neg side of the coil to the neg side of the battery. I had to wiggle the ecm plug red wire to get the green light. could it be a bad ecm plug? What does a green light mean?
     
    Last edited: Jul 24, 2019
  9. 7mopar

    7moparWell-Known Member

    Messages:
    1,711
    Likes Received:
    791
    Joined:
    Dec 21, 2013
    Location:
    Kingsville, MO
    I take it you are referring to the green light on the electronic ignition tester? Green light needs to be on before test can be made. Everything should be on the back of the tester.
     
  10. Power Wagon 440X4

    Power Wagon 440X4Active Member

    Messages:
    76
    Likes Received:
    17
    Joined:
    Aug 8, 2015
    Location:
    Texas
    I went back out and installed another ECM Plug and the new ECM I started out with. Having to wiggle the red wire to get contact was just a future problem or in hitting the first bump. I now have a red light on the neg side but it is not as bright as the pos side. still no fire.
    When I was wiggling the red wire with the key on and cranking it via starter relay it did fire and run for one second. fire up and die. it never did it again no matter how much wiggling so I replaced the plug. 2 bright lights on 2 of the 4 plug holes. What am I missing here?
     
  11. 7mopar

    7moparWell-Known Member

    Messages:
    1,711
    Likes Received:
    791
    Joined:
    Dec 21, 2013
    Location:
    Kingsville, MO
    I will see if I can get the test procedures attached tomorrow. You will need a digital volt meter.
     
  12. Power Wagon 440X4

    Power Wagon 440X4Active Member

    Messages:
    76
    Likes Received:
    17
    Joined:
    Aug 8, 2015
    Location:
    Texas
    Thanks
     
  13. 7mopar

    7moparWell-Known Member

    Messages:
    1,711
    Likes Received:
    791
    Joined:
    Dec 21, 2013
    Location:
    Kingsville, MO
    Files are to large to upload here. Sent you a PM
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice